Expo Push notifications on standalone ios (Testflight)

I’ve some issues when sending push notifications to an ios standalone app currently running in testflight.

When I try the push notification tool Expo push tool. I get the push sent without any error message. I assume that my expotoken now is alright and the problem is elsewhere.

By further investingating the push notifications I ran the following to commands in terminal.
curl -H "Content-Type: application/json" -X POST https://exp.host/--/api/v2/push/send -d '{"to": "ExponentPushToken[sxA_bxGq-7kq58il-****]","title":"hello","body": "world" }'

curl -H "Content-Type: application/json" -X POST "https://exp.host/--/api/v2/push/getReceipts" -d '{"ids":["mylongid"]}'

I get the following error
“The Apple Push Notification service unexpectedly dropped the connection. Retry sending the notification later.” and I’ve tried to send it quite some times so I guess there are som other problems regarding my settings at developer.apple.com

I’ve tried to activate the APN and Apple Push Services on developer.apple.com. Is this all wrong? Do I need anything here at all or can expo handle all these settings?
I did try to detach the app in the past and then I added some settings developer.apple.com. I’ve a hard time finding information on expo webpage about those settings and that is why I’m concerned that I might not need them at all.

Thanks for any advice in advance

I’m trying to startover by deleting all certificates from developer.apple.com and then running

exp build:ios -c

Credentials was created for the production version. But not for developer.
By adding push notifications for the sandbox account it all started working.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.