Expo push notifications error out on production

Please provide the following:

  1. SDK Version: 46
  2. Platforms(Android/iOS/web/all): Android/iOS
  3. Add the appropriate “Tag” based on what Expo library you have a question on.

I have setup my push notifications per the Expo guide. Multiple times (Submitting a EAS build each time). iOS use to work, and has now stopped. I suspect it will start working again once I resubmit the latest app.

Android, however, is giving me this error:

{“data”:{“status”:“error”,“message”:“"ExpoPushTokend[G_oJXJq-mz6PBLUGY28vW]" is not a registered push notification recipient”,“details”:{“error”:“DeviceNotRegistered”,“expoPushToken”:“ExpoPushTokend[G_oJXJq-mz6PBLUGY28vW]”}}}%

Tried another token with the same result (reinstalling the app):
{“data”:{“status”:“error”,“message”:“"ExpoPushTokend[htVz1FB0o8XrTfizniCaOq]" is not a registered push notification recipient”,“details”:{“error”:“DeviceNotRegistered”,“expoPushToken”:“ExpoPushTokend[htVz1FB0o8XrTfizniCaOq]”}}}%

My iOS devices are also giving me these errors, to be clear. Expo notifications use to work, but no longer. Each token generated gives me this error. The only tokens that work, are the ones generated from Expo GO.

When I run my application via Expo Go, the push notifications work fine. When I run my application on the phone (Downloaded from Play Store), it doesn’t work.

The above error is generated using the CURL method. Either way, that token is different on Expo Go and the Live app, which is how I know that its not working.

I’m at a loss. I’ve trippled checked everything, all IDs match.

The only thing that I’m wondering is that, the Play Store account is not the same as the Firebase account. The App IDs all match up, but does the above matter?