Expo publish status 401

Please provide the following:

  1. SDK Version: 35
  2. Platforms(Android/iOS/web/all): all
  3. Expo Version: 3.1.2
  4. Exp Version: 57.2.1

When I run expo publish I get Request failed with status code 401

Error message

Error: Request failed with status code 401
    at createError (/usr/local/lib/node_modules/expo-cli/node_modules/axios/lib/core/createError.js:16:15)
    at settle (/usr/local/lib/node_modules/expo-cli/node_modules/axios/lib/core/settle.js:17:12)
    at IncomingMessage.handleStreamEnd (/usr/local/lib/node_modules/expo-cli/node_modules/axios/lib/adapters/http.js:237:11)
    at IncomingMessage.emit (events.js:187:15)
    at endReadableNT (_stream_readable.js:1094:12)
    at process._tickCallback (internal/process/next_tick.js:63:19)

I’ve tried log out and login and still the same issue. This worked once this morning however I can no longer get it to work

Any help would be appreciated

Could it be that you need to “expo login” or “expo signin” again?

thank you but i did that several times and it’s still not working

Hi. In case this helps, here’s a comment from a previous thread:

By the way, when you say “Exp Version: 57.2.1”, are you talking about the “exp” command line tool? That has been deprecated and you should not need it. expo-cli has replaced it. I doubt it’s causing any problems, but might be best to uninstall it just in case.

1 Like

@wodin thanks for the info. I had already uninstalled exp and uninstalled expo. The reinstalled it again and it’s been working fine. I know I had logged into another account on that machine so your suggestion would have probably worked. Just didn’t see it in time. I’ll keep that in mind if I run into a similar issue again. Thanks

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.