Expo publish not authorized

Hello everyone

below is my expo diagnostics

expo diagnostics

  Expo CLI 3.19.2 environment info:
      OS: Windows 10 10.0.17763
      Node: 13.12.0 - C:\Program Files\nodejs\node.EXE
      Yarn: 1.19.1 - C:\Program Files (x86)\Yarn\bin\yarn.CMD
      npm: 6.14.4 - C:\Program Files\nodejs\npm.CMD
      expo: ^37.0.7 => 37.0.8
      react: ~16.9.0 => 16.9.0
      react-native: https://github.com/expo/react-native/archive/sdk-37.0.1.tar.gz => 0.61.4

I have logged in to my account successfully and I tried to publish my react-native app into expo using below command.
actually, I have build using expo build:android and it was successfully.
but now I’am getting this error:

$ expo publish --non-interactive --max-workers 1 --release-channel dev
[23:28:10] Publishing to channel 'dev'...
[23:28:12] You are not authorized to build @xxx@mail.com/abc-app. The username provided under owner may be incorrect or invalid.

Any ideas on how to fix it? Or what’s going on?

Thank you

Hi @notbrent

Could you please help about this?

Thank you

I have resolved my issue.
it is because I have put owner in my app.json

I removed the owner and now I can publish it.


oh interesting - was the owner a different user than your account?

I used my email that has been registered in expo.io as owner value.
actually, in this doc we have to put username instead of email. https://docs.expo.io/workflow/configuration/#owner
might be need some coffee LOL.
I haven’t tried to update it to username.
I just removed it.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.