Expo notifications work on Android but not iOS. Push receipts are returning an OK

Like the title says I’m having trouble getting push notifications to work on iOS. The code we have works on android and it works on iOS locally, however, when we push to testflight and test the app on a physical device there are no notifications.

Things I have tried:

I’m out of ideas, any help would be appreciated.

Figured it out! build:ios -c is what we needed, --clear-credentials did not do the job.

-c and --clear-credentials are the same thing, see comment below

Hey @skytrobb- those are the same command (expo build:ios -c and expo build:ios --clear-credentials), so I’m confused how one worked while the other didn’t.

Did expo build:ios --clear-credentials end up with an error, or it just had no effect on the standalone app?

yep you’re right, I recently discovered the real fix was our certificate for iOS was updated from p12 to p8. That change occurred between the two builds and I did not realize they were the same at the time so I thought one worked and the other didn’t.

1 Like