Expo not starting any dev tools in the local host

Please provide the following:

  1. SDK Version: 36.0.0
  2. Platforms(Android/iOS/web/all): All

This problem is very weird. I am running an expo based react native app and everything was working fine until a week back. I resumed my work only to find the expo start doesn’t start up the dev tools on the localhost - port 19002. I keep getting ‘cant reach this page’ error message. The logs are as below

Expo DevTools is running at http://localhost:19002
Opening DevTools in the browser... (press shift-d to disable)
Starting Metro Bundler on port 19001.

It was working perfectly and all of a sudden this happens. I used to get Tunnel ready message and everything was perfect. I can’t proceed with my development because the dev server would not even start. I did install FortiClient VPN recently but I deleted all the associated files and I am no longer on it. I am clueless why this is happening.

I tried the following: 1. Uninstalled expo cli, reinstalled it. 2. Cleared all vpn files to the best of my knowledge. 3. Ran other simple react native projects. I encountered the same issue.

Nothing seems to work. Can somebody please help? Is there anything trivial I am missing here? I have a demo to show in a few days. Any help would be highly appreciated.

I solved it after pulling an all-nighter. I was using anti-virus software and the firewall protection was on. I switched it off and that did the magic. Not sure how that got turned on though.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.