Expo Not Opening Latest Project

The problem that I am currently facing is that I have created new projects using cmd with expo. When I run the command “expo start/npm start” my project and after I scanned the QR code using the expo app on my phone, it keeps opening an old project which I have deleted long ago. Please help, I could not continue with my new project because of this issue.

1 Like

In case it’s picking up an older version, maybe you might want to goto App settings for Expo on your phone and delete all data. Else, try reinstalling the app altogether. I had this issue when I would click on the project name under ‘Recent’ category, instead of scanning the new QR code.

Hey @yokaidp9,

As rodiwaa mentioned, clearing the app cache and data is usually a solution to this issue. If that hasn’t fixed it, can you let me know what platform and Expo Client version you are using?

Cheers,

Adam

this is happening to me also, i am using galaxy s5 and windows 10. Also the live reload doesnt work. If i delete the app and re install it works the first time, then is hard to get the new code to load after that.

I tried clearing the data already, it didnt work for me. I have also reinstalled the expo app several times and even tried reinstalling expo on my computer still the same problem ;(

I am using android platform, Huawei Nova 2i. My Expo Client version is 2.10.1

Error: Asset not found: D:\yierling\assets\images\yokaiv2.png for platform: null
at D:\yierling\node_modules\metro\src\Assets.js:147:13
at Generator.next ()
at step (D:\yierling\node_modules\metro\src\Assets.js:326:347)
at D:\yierling\node_modules\metro\src\Assets.js:326:507

This is the error that I got, apparently my old app data seems to be “stuck” or something.

1 Like

Problem fixed. I cleared all the data and cache from Expo through the settings on my phone.

5 Likes