Expo not install

when i trying to install by npm install expo-cli --global it shows following error . what i do for this
npm WARN deprecated joi@14.0.4: This version has been deprecated in accordance with the hapi support policy (hapi.im/support). Please upgrade to the latest version to get the best features, bug fixes, and security patches. If you are unable to upgrade at this time, paid support is available for older versions (hapi.im/commercial).

That message is just a warning. Please ignore it.

I’m having the same problem right now and i’m new to expo if someone can help how to resolve this error will be appreciated

No, after complete the overall process when we use expo command like expo start or expo --version it shows ‘expo’ is not recognized as an internal or external command,
operable program or batch file.

Please post the whole error. The part you quoted is just a warning. Post it like this:


EDIT: @sandeepjangra I’ve just realized that your “not recognized as an internal or external command” error message implies you’re trying to install expo-cli on Windows. I have never tried that before. Only macOS and Linux.

I think there are three different environments you could try to use, so maybe try them one by one and if you still get errors then post the full error logs here and say which environment(s) you got the errors in. i.e.:

  1. cmd.exe
  2. Powershell
  3. bash (a.k.a. WSL)

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.