Expo keeps crashing on local projects on Android.

A project which was working fine a couple of days ago (sdk 26.0.0) has stopped working now. When trying to open it, the app crashes with only the “Expo keeps stopping” error message. I proceeded to update the cli, the sdk and the android app to their latest versions, however, even now when i run a project with expo init and expo start, the app simply crashes. The apps in the Featured section of the expo android app seem to be working fine. Does anybody have any experience with this? This has pretty much killed all the expo projects i am working on and any insight would be greatly appreciated.

Hey @pbandjs,

Can you try clearing the Expo Client’s app data and cache. Android seems more prone to caching issues so clearing this every now and then never hurts. Let me know if that fixes it.



Hey adamjnav. Thanks for the tip. Clearing my app cache worked on making new projects work, but projects built on the old sdk still fail. There was a new Android client released yesterday(2.10.2 I think) which fixes the issue completely.

1 Like

Ah, of course. I should’ve asked if you had the newest Android Client version installed. Glad you figured it out though! Good luck developing moving forward!

All the best,


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.