Expo is not installing on iOS Simulator

Ever since I upgraded to Expo SDK 44.0.0, expo won’t install on the iOS Simulator. I had to erase the content and settings on the simulator, since it didn’t support SDK 44.

Here is what I tried so far:

  • run expo client:install:ios
  • uninstall and reinstall expo
  • uninstall and reinstall watchman
  • tried different simulators (15.0 that I used so far)
  • creating a new blank expo project
  • open the simulator first and then npm start
  • I even did a complete MacBook reset (factory, needed to wipe anyway) and reinstalled following the expo documentation.

There is absolutely no error. When trying to open the app on the simulator, it says success. When I run expo client:install:ios it says “Done!” but nothing happens.

I’m out of ideas.

Hey @crypticmindz, can you run expo diagnostics and paste what the terminal prints out here?

Hey @adamjnav.


OS: macOS 11.5.2
Shell: 5.8 - /bin/zsh
Node: 16.13.2 - /usr/local/bin/node
npm: 8.1.2 - /usr/local/bin/npm
Watchman: 2022.01.17.00 - /usr/local/bin/watchman
Platforms: DriverKit 21.2, iOS 15.2, macOS 12.1, tvOS 15.2, watchOS 8.3
Xcode: 13.2/13C90 - /usr/bin/xcodebuild
expo: ~44.0.0 => 44.0.5
react: 17.0.1 => 17.0.1
react-dom: 17.0.1 => 17.0.1
react-native: 0.64.3 => 0.64.3
react-native-web: 0.17.1 => 0.17.1
expo-cli: 5.0.3
Expo Workflow: managed

Actually solved this.

The problem was sudo. Expo needs to be installed without sudo. If it throws errors (EACCES) the owner of /usr/local/lib/node_modules needs to be changed to you, for me the owner was root. I changed the owner with the help of this post:

After that, I was able to install Expo without sudo and when I init a new project and run on iOS Simulator, expo finally installed on the simulator.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.