Expo iOS build comes with random icon

Something weird happened after I built the app with expo for iOS standalone ipa. I uploaded the ipa to itunes connect and test it with testflight, however, the app icon was something random, see below:


I believe this icon is not expo’s “new icon”? And it looks very different from my app’s icon (from color to shape), so it cannot be my icon was somehow distorted? I wonder what happened?

The app icon of previous builds looked right, and the current build seems to have the right JS bundle (the app seems to behave properly). The only thing that is not right is the app icon.

I’d love to provide more information if needed.

same thing happened to me so I ran another build process and re-uploaded the APK which fixed the issue. Make sure you change the version on app.json before doing so.



Thanks for sharing! I actually did it but it didn’t work. I am wondering what was going on, and this could be an issue if that icon is actually someone else’s, imagine next time it is not the icon goes wrong but the js bundle…

Forgot to ask, did you also see the same icon I showed in the post? Or it was something else?

1 Like

totally agree! and yep, I saw the exact same icon

yeppp me too

I’ve changed the version and build number in app.json and rebuilded it several times, but the my app’s icon keep replaced by the “new icon”.

exp --version : 55.0.5
expo sdkVersion: “29.0.0”

I am facing same problem, icon was replaced by random new icons

“sdkVersion”: “27.0.0”
expo version : “55.0.4”


We are aware of this issue. Potential fix was just deployed to our builders. Please rebuild your app and check if the icon is correct. If not please provide us with your build id or experience name.

Sorry for that inconvenience.


Same issue.
I have tried triple.
Do you have any solutions?

The last App I uploaded is perfect. The issue just comes up from last week when I do another App.

Here is my app.json file.

“expo”: {
“name”: “Go3Rewards Merchant”,
“description”: “Go3Rewards APP for Merchant.”,
“version”: “3.0.0”,
“sdkVersion”: “27.0.0”,
“icon”: “./assets/images/icons/1024.png”,
“ios”: {
“bundleIdentifier”: “com.go3solutions.go3rewards”,
“buildNumber”: “3.0.2”,
“icon”: “./assets/images/icons/1024.png”,
“merchantId”: “”,
“supportsTablet”: true,
“isTabletOnly”: false,
“infoPlist”: {
“NSCameraUsageDescription”: “This app uses the camera to scan barcodes on clients apps.”,
“NSPhotoLibraryAddUsageDescription”: “This app used the camera to scan barcdoes on clients app.”
“orientation”: “portrait”,
“android”: {
“package”: “com.go3rewards.merchant”,
“versionCode”: 1,
“permissions”: [
“splash”: {
“image”: “./assets/images/splash.png”,
“resizeMode”: “cover”,
“backgroundColor”: “#ffffff
“assetBundlePatterns”: [

We believe we managed to pin down problem and we’re are in process of deploying fix right now. What we believe was cause of a problem is a 3rd party library used to resize icons.

Another update on icons issue - the fix has just been deployed. We’re 99.9% sure that we really fixed the problem this time. Also, no other assets than icons were leaking between different users apps. Sorry guys for the inconvenience.

Thanks for the great work! Rebuilding solves the issue for me. Would like to hear how it works for other people.

Thank you so much. It works now.
You guys did a great job. I like Expo as easier and faster.

it works!!!
thanks all :+1::+1::+1:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.