expo iOS:build building with Expo App Icon

I am unable to get expo build:ios to build with anything other than the expo icon.

In the app.json ios.icon field, I have

But when I try to upload the build to the iOS App Store, it is just the expo icon. How do I get rid of the expo icon and get it to be my own?? I’ve tried this with many different icon locations and sizes, but nothing is working.

What can I do to figure out the issue?

Hey @grendorf, sorry about this issue. Can you verify that the path to the icon is correct, and that it follows the required specifications?

If neither of those fixes it, I’d try using the base icon field, rather than the ios.icon field and see if the problem still persists afterwards.

@charliecruzan Thanks for the quick reply.

I checked, the path to the icon is correct. And when I intentionally put in a wrong path, I get an error, so that all seems correct. It does follow the requirements. And then i tried with both the icon in the ios.icon field and then removed it and changed build and version numbers to confirm and I am still just getting the expo icon. Is there a way to change it once I get the ios build? Or is there a way I can see the expo build logs on the icon creation to see what is going wrong?

Note: I also tried putting the icon in different filepaths etc. Just to try and get around any sort of bad reference.

Can you give me the build id so I can take a deeper look?

What’s the best way to do that? Do you have an email address I can message?

Yeah! go ahead and send an email to secure@expo.io with the IDs

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.