$ expo install expo-location leads to npm exited with non-zero code: 243


Expo CLI 5.2.0 environment info:
OS: Linux 5.4 Linux Mint 20.3 (Una)
Shell: 5.0.17 - /bin/bash
expo: ^42.0.0 => 42.0.4
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-42.0.0.tar.gz => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
Expo Workflow: managed

this occurs when I run:

$ expo install expo-location

Installing 1 SDK 42.0.0 compatible native module using npm.

npm install

npm exited with non-zero code: 243
Error: npm exited with non-zero code: 243
at ChildProcess.completionListener (/usr/local/lib/node_modules/expo-cli/node_modules/@expo/spawn-async/src/spawnAsync.ts:65:13)
at Object.onceWrapper (node:events:640:26)
at ChildProcess.emit (node:events:520:28)
at maybeClose (node:internal/child_process:1092:16)
at Process.ChildProcess._handle.onexit (node:internal/child_process:302:5)

at Object.spawnAsync [as default] (/usr/local/lib/node_modules/expo-cli/node_modules/@expo/spawn-async/src/spawnAsync.ts:26:19)
at NpmPackageManager._runAsync (/usr/local/lib/node_modules/expo-cli/node_modules/@expo/package-manager/src/NodePackageManagers.ts:175:31)
at NpmPackageManager.installAsync (/usr/local/lib/node_modules/expo-cli/node_modules/@expo/package-manager/src/NodePackageManagers.ts:91:16)
at NpmPackageManager.addWithParametersAsync (/usr/local/lib/node_modules/expo-cli/node_modules/@expo/package-manager/src/NodePackageManagers.ts:105:18)
at actionAsync (/usr/local/lib/node_modules/expo-cli/src/commands/installAsync.ts:141:3)

Since I could not find a solution so far, I would like to ask here:

  • What could be a reason for this behavior?
  • How can this be resolved?

Thanks in advance!

Hey @k79llvsbcjcuzagm, can you try directly using npm to install? Also, try installing via yarn add to see if that works as expected?

npm i expo-location worked. Great, thank you @adamjnav !

I had some version issues afterwards: expo-location version ~12.1.2 was expected, but I had 14.0.2. It was not difficult to resolve this by adapting package.json
Since I want to move up from Expo SDK 43 from SDK 42 I will have to tidy up some dependencies anyways. Both should/could prevent this from happening again, I guess.

For the moment it feels good to see the coordinates in the app. :slightly_smiling_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.