when implementing imagepicker with expo-image-picker, It is working fine with emulator but whenever I run this on actual device using expo-cli app, ImagePicker allows me for picking but after picking image project is reloading and image cannot be picked.

Project is reloading as soon as I pick image and here is my code of how I am picking image:
async () => {

let result = await ImagePicker.launchImageLibraryAsync({

  mediaTypes: ImagePicker.MediaTypeOptions.All,

  allowsEditing: true,

  quality: 0.6,


if (!result.cancelled) {

  this.setState({ image: result.uri });



I also asked for user permission for medialibrary but I am thinking it not worked:
if (Platform.OS !== “web”) {

  const { status } = ImagePicker.requestMediaLibraryPermissionsAsync();

  if (status !== "granted") {

    alert("Sorry, we need camera roll permissions to make this work!");



Please anyone help me, I searched whole internet and even tried 100’s of methods and ways but none worked for me. Due to this bug 18hrs of my time got wated.

Any help is greatly welcomed. Thanks in advance