Expo Icon appears in iTunes Connect

Hey guys, trying to deploy my iOS app to the App Store. Everything was going fine. I used Application Loader 3.7 to upload the .ipa file that exp build:ios generated for me. In iTunes Connect, I uploaded my iOS App icon just fine, but then once I selected a build, the app icon got replaced by the expo arrow up icon. It’s strange because I deleted all expo icons in the assets folder and there’s no reference to it in app.json. I’m not really sure what is going on here and I can’t seem to just manually change the app icon. Anyone around that knows what’s going on?

I feel like this may be an issue with Xcode 9 and adding icons with the new version. From iTunes Connect: This icon will be used on the App Store. For apps built with Xcode 9 or later, add this icon in the build. For apps built with earlier versions of Xcode, add the icon here.

Here is my app.json

  "expo": {
    "name": "Washloft",
    "description": "On demand laundry for Greater Boston",
    "slug": "washloft",
    "privacy": "public",
    "sdkVersion": "20.0.0",
    "version": "1.0.0",
    "orientation": "portrait",
    "primaryColor": "#cccccc",
    "icon": "./assets/icons/iosIcon.png",
    "loading": {
      "backgroundImage": "./assets/icons/splashImage.png",
      "backgroundColor": "#42acab",
      "hideExponentText": true,
      "splash": {
        "backgroundColor": "#42acab",
        "image": {
          "ios": {
            "backgroundImage": "./assets/icons/splashImage.png"
    "packagerOpts": {
      "assetExts": ["ttf", "mp4"]
    "ios": {
      "supportsTablet": true,
      "bundleIdentifier": "com.washloft.washloftUserApp"
    "android": {
      "package": "com.washloft.washloftUserApp"

iTunes Connect


I tried all possible things
but still the same issue

Hi, same issue here with Xcode 9.

When uploading with the Application Loader, I see my icon.
But then when the build has been processed, on ItunesConnect I select it and then the icon is not taken into account but reverted to the Expo icon.

Looking for help as well.
I will revert to Xcode 8 in the meantime to see if I can make it.

Hi, we recently pushed a change to address this, so I’m wondering if you created your archives before our deployment finished (probably over the weekend).

Can you try making another build and take note of the build id? If the bad icon behavior still isn’t fixed, can you let me know what the build id was?

I am experiencing the same issue as well. Just started over the last 48 hours seems. Here’s an example build ID fc9bb1cd-c8f2-4c33-bad3-4d814a32e0b7

1 Like

Can any of the posters here also try the following?

  1. Make a simulator build (with -t simulator)
  2. On the resulting .app file, “Show package contents”
  1. See if any of the resources inside your build look like the erroneous Expo logo:


Hey @ben

I’m at work right now so I can’t make a new build. But I made a few build last night trying to fix this issue. One of the IDs was: ff8482d8-75b9-4042-bcec-9dfce1c66ade

As a note, I tried to look at the contents of the .ipa file. I saw an article last night that said to change the .ipa to .zip and extract the contents. Looking at the content of “Exponent” I was able to see all of the icons you listed above and I specifically tried looking for an expo icon but didn’t see one.

When I get home tonight I can run the steps you listed above to see if I get the same thing or not.


I just created a simulator build with ID b7e0c62f-12c2-480a-b8f9-776c4706a043

The AppIcons are all of my app icon, not the Expo icon which is showing up as the icon in testflight (although as I said earlier, only very recently - builds last week / over the weekend did not have this issue)

Using Xcode 8.3.3 I see my icon in the package content after downloading a simulator build created with exp build:ios -t simulator

Here’s a screenshot

I continue the process to see if everything goes all right

So I used the Application Loader
I saw the correct icon
Then uploaded it was fine
I clicked save and now, Expo icon back again :sweat_smile:


Several builds later, still not working unfortunately.
Do you have any other idea which may cause this issue?

Thanks everyone for the additional info. The builds being generated do look correct (they don’t contain the Expo logo), but nonetheless it’s showing up in iTunes.

I’m looking into this today. Hope I can come to a diagnosis quickly, but I’m not sure yet.


Thanks a lot for looking into it!

Same problem, build looks ok, but after submitting it to itunes connect, the expo logo appears. I hope it will be fixed quickly. Thanks for looking into it.

1 Like

Ok, it seems like Xcode 9 (which is what we’re running on our build machines) compiles the iTunes Connect 1024x1024 marketing icon differently than all the other size icons.

I’ve started working on some automation to do this when we create your builds. It will take me some time, I’ll try to get it deployed as soon as it’s ready. I wouldn’t count on that happening today, but maybe it’ll turn out to be less work than I expect.


Thanks for your reactivity! Hope you’ll find a fix soon. Let us know if we can help

With XCode 8.3.2 I have the same problem: Images inside the build look good, but after submitting to iTunes Connect, the expo logo appears as the App and watch icons. Let me know if I can help in any way. Thanks

Hi all - please give your builds another try. We’ve deployed a tentative fix for this issue.

Let me know if the issue still occurs on a new build.

Edit: One confusing thing is that the old Expo icon won’t go away until iTunes finishes “processing” your new build. So make sure to select the new (fixed) build in iTunes Connect.


Fixed our issue, thanks Ben!

1 Like

fixed for me as well.

1 Like

Thank you so much for the fix. Our app icon as well as the push notification icon are now showing correctly.