Expo.Google.logInAsync dosn't works on sdk 32

When I call Expo.Google.logInAsync I never get the result, and if I tried to call it again the application closes.

Hey @emmanuelid,

With no code or information about your environment/tests, it’s near impossible to help out.



Hi @adamjnav ,

I have the same problem after upgrading sdk from 30 to 32.
My app is not detached. I am using the Expo app on Android.
I can see the screen for selecting google account appearing and also the consent one.
When the Google auth flow finish, I am taken back to the Expo app while the screen of my app stays in the background. When I activate my app, I is still on the login screen. I hit my login button and whole Expo app crushes.

Below is the code of my handleLogin method.
Let me know if in need of more information.

handleLogin: async () => {
  try {
    const authConfig = {
      androidClientId: Constants.manifest.extra.androidClientId,
      iosClientId: Constants.manifest.extra.iosClientId
    const auth = await Google.logInAsync({
        androidClientId: Constants.manifest.extra.androidClientId,
        iosClientId: Constants.manifest.extra.iosClientId
    console.log('never executes')
    await doLogin(auth)
  } catch (e) {
    console.log('no error either')

Downgrading to sdk 31 fixes the issue.

Hi,same problem here
Any way except downgrade??

@penchob How can I downgrading?

@emmanuelid I just followed the instructions here:

1 Like

@penchob It worked, thank you very much.

i forgot to change the app.jason expo version from “31.0.0” to “32.0.0” when upgrading to SDK 32, at that time i only updated package.json, now i update app.json and everything works just fine


Is there a way to fix that without downgrading?

1 Like

@zenorocha it looks like @penchob got it to work when also updating app.json (not just package.json) versions

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.