expo-google-app-auth stopped working after upgrading to SDK 42

Please provide the following:

  1. SDK Version: 42
  2. Platforms(Android/iOS/web/all): Android
  3. expo-google-app-auth, firebase

Hey guys,

Look, after upgrading my app from SDK 40 to SDK 42 I started facing an issue with expo-google-app-auth when I publish my app to Play Store(Internal Testing).

When a user tries to Sign in using Google, it’s supposed to open the web view where the user selects the account he wants to log in with, Well, this stopped working after the upgrade, it just doesn’t show anything, it never resolves after calling logInAsync nor throw any error.
This only happens when I deploy my app to Google Play (.aab). if I compile my app in .APK format and I install it directly to my phone it works fine.

I double-check my hashes in firebase, Google Cloud, and Play Console (I know we should replace the hash once we deploy to the play store with the one provided by them), and also downloaded a new google-service.json file from firebase and all stay the same.

I don’t know what can be causing this issue. I have tested this in Android 8.1.0 and Android 9.1.0 with the same result. It only worked on my brother’s device (don’t know his android version right now)

Here are the involved library’s versions
firebase 8.2.3
expo-google-app-auth ~8.2.5

Any idea on the subject?

Hey @edwinmunguia, we’ve deprecated that module in favor of the AuthSession module. If possible I would strongly recommend migrating.

Thanks for replying @adamjnav… Will try this module and I’ll let you know how it goes.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.