Expo Go download bundle broken

Since yesterday, bundle download went from seconds to SEVERAL MINUTES
It happened in the middle of the day when I had been working with it for hours…
It happens with any app, on any network, on Android (Samsung & Huawei) and iOS (iPhone & iPad)
I updated all my packages, node, npm, expo, …
What happening ??

I launched the project from a Mac, all is working fine. So the problem come from my PC.
But i don’t have any idea…

Expo-cli 5.4.3
Latest Expo Go

Hi @maximerichet

Is it possible you’re using --tunnel mode on your PC? If so, the download would be going out over the Internet and back in again, so could potentially be slow (although “several minutes” would be unusual).

I’ve also had slow bundle downloads in the past if I was sitting with my laptop in an area with relatively weak WiFi signal. In this case the laptop and the phone both have poor connections to the WiFi AP. If I am in that situation and don’t want to move, it helps to turn on my phone’s mobile hotspot and connect to that from my laptop so they can talk directly to each other instead of via the WiFi AP.


The wifi is pretty fast, it’s a corporate network, and I’ve never had a problem with that. In addition, even making a hotspot, it’s still very slow from my pc. On the other hand, from a Mac on the same wifi network, the speed is normal, as before.

I think it’s from Windows 11 and a recent update, because I haven’t installed anything else since, nor added a virtual network card or anything.

It’s very annoying because at the moment I have to plug in my device and “Run on Android device”, so I can’t do it with iOS, and the development takes longer, and I don’t have that time…
Usually I use 3-4 devices at the same time.

I’m not sure what could cause that then. And you’re definitely not using tunnel mode?

The only thing I can think of to suggest is either trying WSL2 if you’re not already using it (although I think you’ll have to forward port 19000 from the host to WSL2 (and maybe others). Or maybe try Linux in a virtual machine. At least with WSL2 I think you should be able to continue using whatever development environment you’re currently using and just run expo start in WSL2.

Note: I do not have a Windows machine to test this stuff out on.

Tunnel mode is much faster than LAN :sweat_smile:
But fast refresh doesn’t work…

It seems a bit tricky to run multiple projects (sometimes at same time)


Running expo start in multiple projects at the same time will allocate different ports for each of them, but otherwise there should not really be a problem, I don’t think.

I finally found why !
Bitdefender was bridging wifi with a virtual card he created for his firewall.
Only solution i found was to disable his firewall and remove the bridge in my network cards settings.
Now everythings is back to normal.

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.