Expo go app is crashing on my simulator

I installed a project based on the Expo SDK 44. And when I run ‘expo start’,
Expo go app is installed in the simulator. I think at this time, old version expo app is installed.
I can check all features with the Expo go app.

After I upgraded the project with Expo SDK 46, and it says the expo go app is outdated and ask me to install with new.

image

If I reinstall the Expo Go app, the Expo Go app keeps crashing. I’ve attached the video here:

And if I didn’t upgrade, the app asks me to upgrade with new version.

I’ve checked with IOS14 simulator, so I am not sure it will be crashed on the Android also

Looking forward to hearing from you.

Best regards

Akihiro