Expo go always opens the old app version

After making some updates in the app, I ran expo build:ios --release-channel staging
Then tried opening the app in Expo go on ios, but it always shows the old version. I even tried to reinstall Expo go and delete its cache.
Any ideas on how to pull the latest version?

I’ve got the same problem, my Expo Go App only display default releases (e.g. expo publish without specifying --release-channel) and does NOT pick up anything that have a release-channel specified.

However, all releases are properly listed when I run expo publish:history, I just can’t install or access anything other than default.

Why is it? Is it an Expo bug or is it intended? Or is there something we did wrong or settings we missed?

I have the latest Expo Go & Expo SDK v40

my app.json file:

  "expo": {
    "name": "xxx Mobile App",
    "slug": "xxx-mobile",
    "version": "0.0.2",
    "orientation": "portrait",
    "icon": "./assets/icon.png",
    "entryPoint": "./node_modules/expo/AppEntry.js",
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    "updates": {
      "enabled": true,
      "checkAutomatically": "ON_ERROR_RECOVERY",
      "fallbackToCacheTimeout": 0
    "assetBundlePatterns": [
    "ios": {
      "bundleIdentifier": "com.xxx.mobileapp",
      "supportsTablet": true
    "android": {
      "package": "com.xxx.mobileapp",
      "permissions": [
    "web": {
      "favicon": "./assets/favicon.png"