Expo generated APK not working but everything in the Expo App Works fine

I’m developing an app which is perfectly working on the Expo Client Android App and Android Simulator Expo App.
I generated APK file using the exp build:android and gone with the whole process of setting up the API key and OAuth Client ID as am developing an app with Pedometer.
I installed the APK file on my mobile but it’s crashing continuously.
I mean the app is getting restarted and it’s skipping some screens in the createStackNavigator.
I have used three stacks and all of them in a switchNavigator
can any one help me why its happening.
thank you in advance.


are you asking for permissions appropriately? that’s my first guess.
otherwise, its hard to guess too much without seeing all your code and configuration.

hey @ccheever ,
by asking permissions,
you mean permissions like

"permissions": [ "ACCESS_COARSE_LOCATION", "ACCESS_FINE_LOCATION", "CAMERA", "MANAGE_DOCUMENTS", "READ_CONTACTS", "READ_CALENDAR", "WRITE_CALENDAR", "READ_EXTERNAL_STORAGE", "READ_INTERNAL_STORAGE", "READ_PHONE_STATE", "RECORD_AUDIO", "USE_FINGERPRINT", "VIBRATE", "WAKE_LOCK", "WRITE_EXTERNAL_STORAGE", "com.anddoes.launcher.permission.UPDATE_COUNT", "com.android.launcher.permission.INSTALL_SHORTCUT", "com.google.android.c2dm.permission.RECEIVE", "com.google.android.gms.permission.ACTIVITY_RECOGNITION", "com.google.android.providers.gsf.permission.READ_GSERVICES", "com.htc.launcher.permission.READ_SETTINGS", "com.htc.launcher.permission.UPDATE_SHORTCUT", "com.majeur.launcher.permission.UPDATE_BADGE", "com.sec.android.provider.badge.permission.READ", "com.sec.android.provider.badge.permission.WRITE", "com.sonyericsson.home.permission.BROADCAST_BADGE" ],

permissions like these or any other ?

i know that all those permissions are not needed but i just put them coz i don’t have an idea which ones to use particularly and which ones to not.
if you are talking about the above permissions, i have used them.
thank you.


@ccheever is talking about in the documentation for Pedometer: https://docs.expo.io/versions/latest/sdk/pedometer where there is a ton of example code to check the state of whether or not Pedometer is available.

We need some details around your application logic, not just your configuration.

In addition, it would be really helpful if you shared your SDK version!

Thanks a bunch for bearing with us @hmadugula

the sdk version is 27.0.0
I checked many code examples of the pedometer.
The pedometer is available.
from the docs : Pedometer.isAvailableAsync(): {this.state.isPedometerAvailable} => this returns true
Well, I have a doubt.
Is there any problem with the projects created with exp init and APK generated from those?
I’m asking this because, I created my project with create-react-native-app and followed the same process of generating the APK which worked completely fine and it didn’t crash.
thank you

Hey @hmadugula! Can you post your code somewhere? I don’t have a great guess of what’s going on so it’d be easier if we could reproduce it.

Have you tried running locally with production mode?

You can also get useful device logs with adb logcat. It’s quite verbose but will probably print some stack trace when it crashes

hi @hmadugula if you could make an issue at https://github.com/expo/expo/issues with a repro that’d really help us figure out what went awry. thanks!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.