Expo eject => No Podfile.lock is created.

Hi all!

I’ve ejected my app from Expo, and after doing so, ran npm install && cd ios && pod install. Although a Podfile was created, no Podfile.lock was created. Before ejecting, I was running Expo SDK 40.

Is there an issue in the installation process? Is there something that I’m overlooking and not doing?

Below is my terminal output from ejecting:

Below is my terminal output after running ran npm install && cd ios && pod install:

Thanks in advance for the help!! :slight_smile:

hi there! notice at the bottom of your second screenshot there is an error. this is what would have caused the original pod install to fail also.

try running pod repo update and then pod install again

Hi Brent–thanks fro helping!

I went ahead and navigated to the iOS director and ran the commands you suggested. However, I still get the same error. I also checked the GitHub installation documentation for installing Lottie for React Native, and I’ve followed them precisely.

Here’s my terminal output.

What do you think the issue may be now?

it seems like maybe your node_modules state isn’t correct. do you have node_modules/lottie-ios? maybe delete package-lock.json and node_modules and run npm install again

if that doesn’t help, can you share your repo on github? i’m brentvatne

Somehow, I was able to get the pod install to work. Since the error stated that lottie-react-native was resolved to 2.6.1, which depends on lottie-ios (-> 2.5.0), I ended up doing the following in the terminal.

  1. npm install lottie-react-native lottie-ios@2.5.0
  2. npm install && cd iOS && pod install

Thankfully the pod install worked correctly and all unimodules were successfully installed as well. However, now I’m forced to use lottie-ios: v2.5.0 and lottie-react-native v2.6.1.

Interestingly, I was previously using lottie-ios v.3.1.8. Is there a way to get back up-to-date with the latest versions for each respective library, without having to severely downgrade?