Expo Eject Fail

When I run yarn eject, my project cannot be ejected successfully. I’ve tried several times but it will always fail.
This is the terminal output, may anyone give me a help?

❯ yarn eject
yarn run v1.22.17
warning ../../package.json: No license field
$ expo eject
Your git working tree is clean
To revert the changes after this command completes, you can run the following:
  git clean --force && git reset --hard
request to https://registry.npmjs.org/expo-template-bare-minimum failed, reason: read ECONNRESET
✖ Failed to create the native project.
You may want to delete the `./ios` and/or `./android` directories before trying again.
error Command failed with exit code 1.
info Visit https://yarnpkg.com/en/docs/cli/run for documentation about this command.

I’m using "expo": "~43.0.2" and expo-cli of v5.0.1 locally.

Hi @megrax

Are you behind a proxy server or something? Expo is trying to fetch the bare template and the connection was reset.

Doing the following might shed some light on the networking problem. Run the following:

curl -v -I https://registry.npmjs.org/expo-template-bare-minimum > headers.txt 2> verbose.txt

and then post the contents of headers.txt and verbose.txt.

1 Like

Are you behind a proxy server or something?

Exactly! I AM having proxy, due to some network issues. So I ran unset http_proxy https_proxy in my terminal and it ejected successfully!
I didn’t realize that it would be an issue of the proxy. Thank you very much bro @wodin ! :rocket:

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.