Expo EAS Build keeps failing for iOS

[!] Unable to find a specification for UMCore depended upon by EXHaptics
You have either:

  • out-of-date source repos which you can update with pod repo update or with pod install --repo-update.

  • mistyped the name or version.

  • not added the source repo that hosts the Podspec to your Podfile.


[!] <PBXResourcesBuildPhase UUID=13B07F8E1A680F5B00A75B9A> attempted to initialize an object with an unknown UUID. 83D4B40124E74739BEC38D5B for attribute: files. This can be the result of a merge and the unknown UUID is being discarded.

pod exited with non-zero code: 1

I’m in a managed workflow with the latest eas-cli version.

Hi! It looks like you just pasted the actual error output, which isn’t too helpful. What have you tried so far to fix it? There are a list of possibilities in the actual error message

I don’t know what to do, this is my first time trying to EAS build. I’ve looked online for help, still can’t find one. For now I’m just using the good old expo build:ios :slight_smile:

can you share a link to your build page? and your package.json for your project

1 Like


  "build": {
    "development": {
      "distribution": "internal",
      "android": {
        "gradleCommand": ":app:assembleDebug"
      "ios": {
        "buildConfiguration": "Debug",
        "image": "latest"
    "preview": {
      "distribution": "internal"
    "production": {}


  "expo": {
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    "updates": {
      "fallbackToCacheTimeout": 0
    "assetBundlePatterns": ["**/*"],
    "ios": {
      "supportsTablet": true,
      "usesIcloudStorage": true,
      "usesAppleSignIn": true
    "android": {
      "adaptiveIcon": {
        "foregroundImage": "./assets/adaptive-icon.png",
        "backgroundColor": "#FFFFFF"
    "web": {
      "favicon": "./assets/favicon.png"
    "description": ""

root directory

I’m running into this same issue. Any luck?

1 Like

I actually ran into a different error now

I was able to fix this after moving to Expo SDK v43 and removing expo-yarn-workspaces from my monorepo.

1 Like

I’m getting a very similar error too. Link to build

I’m on SDK 43 (but I’m not using expo-yarn-workspaces)

Building worked when I was on SDK 41 but I updated to 43 because my build wasn’t working on ios 15.

I’m not sure how to follow the suggestions listed in the error output because the docs for the “cocoapods” field just list a version number. Not sure how to run those commands (like “pod repo update” etc.)


  • tried disabling cache and using image latest. Still getting same error
  • tried downgrading to Expo SDK 42.0.5. Still getting similar error (Unable to find a specification for UMFileSystemInterfacedepended upon byEXAV``)
  • tried running "eas-build-post-install": "pod install --repo-update", but since pod install fails, it appears the build does not run this script

are you able to share a reproducible example of this?

The github repo is private, but I could add you if that would help

that would be helpful! i’m brentvatne on github

1 Like

Invite sent

looking at your project it seems that the dependencies are incorrect. have you tried running expo doctor? one thing that jumps out immediately is that you’re using the version of react-native for sdk 41 but you’re using expo sdk 43

i ran expo upgrade in your project and answered yes in:

:heavy_check_mark: You are already using the latest SDK version. Do you want to run the update anyways? This may be useful to ensure that all of your packages are set to the correct version. … yes

and it updated all of these packages:

installing cocoapods worked fine after doing this.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.