expo doctor failing due to @expo/config-plugins

The expo-cli doctor command is currently failing for me both locally and while building the app on EAS Build:

❯ expo-cli doctor
Expected package @expo/config-plugins@^5.0.0
Found invalid:
  @expo/config-plugins@4.1.5
  (for more info, run: npm why @expo/config-plugins)

Result of running npm why @expo/config-plugins as suggested (using a gist due to character limits): Result of running npm why @expo/config-plugins · GitHub

I’ve tried running expo-cli doctor --fix-dependencies but that still doesn’t fix the issue.

Versions:

  • Expo SDK: ^46.0.0
  • Expo CLI: 6.0.5

Hi @tiltbike

First try: npx expo install --fix

If that doesn’t help, try removing you package-lock.json (or yarn.lock) and node_modules and reinstalling your dependencies.

If that still doesn’t fix it, please post your dependencies and devDependencies here.

2 Likes

Thanks a lot! That worked. My bad, should’ve tried this earlier :sweat_smile:

1 Like

Well, expo-cli doctor --fix-dependencies should have worked, but unfortunately it can’t always fix things.

1 Like