Expo Dev Tools doesn't open automatically and Expo Go crash in iOS simulator

Hey guys, so I just bought a new Macbook Air (M1) and tried to run one of my projects there. When I run expo start --ios everything works fine, but I don’t see the windows for developer tools opened and Expo Go in iOS simulator crashed (it won’t open the app). I tried to create a fresh project with expo init and it still has the problem.

I tried to open it with expo in my phone and it works fine, just the iOS simulator (haven’t try android simulator yet)

Here are my expo diagnostics:

Expo CLI 5.0.1 environment info:
System:
OS: macOS 12.0.1
Shell: 5.8 - /bin/zsh
Binaries:
Node: 16.13.1 - /opt/homebrew/opt/nvm/versions/node/v16.13.1/bin/node
Yarn: 1.22.17 - /opt/homebrew/bin/yarn
npm: 8.1.2 - /opt/homebrew/opt/nvm/versions/node/v16.13.1/bin/npm
Watchman: 2021.12.13.00 - /opt/homebrew/bin/watchman
Managers:
CocoaPods: 1.11.2 - /usr/local/bin/pod
SDKs:
iOS SDK:
Platforms: DriverKit 21.2, iOS 15.2, macOS 12.1, tvOS 15.2, watchOS 8.3
IDEs:
Android Studio: 2020.3 AI-203.7717.56.2031.7935034
Xcode: 13.2.1/13C100 - /usr/bin/xcodebuild
npmPackages:
expo: ~43.0.2 => 43.0.3
react: 17.0.1 => 17.0.1
react-dom: 17.0.1 => 17.0.1
react-native: 0.64.3 => 0.64.3
react-native-web: 0.17.1 => 0.17.1
Expo Workflow: managed

Please let me know if you know the solution. Thanks!

I found the problem, I didn’t install Rosetta for the Xcode. It’s fixed now.

1 Like