expo customize:web fails without giving reason

Running expo customize:web and picking “index.html” results in no changes and doesn’t give a reason why.

Copy paste:

$ expo customize:web

✔ Which files would you like to generate? ›

› Exiting with no change...

ls and ls -a show no index.html was added (and not in a web or public etc directory). No reason is given why we exited with no change instead of making the change.

Expo diagnostics:

  Expo CLI 4.2.1 environment info:
      OS: macOS 10.15.7
      Shell: 5.7.1 - /bin/zsh
      Node: 14.5.0 - /usr/local/bin/node
      npm: 7.5.4 - /usr/local/bin/npm
      iOS SDK:
        Platforms: iOS 14.4, DriverKit 20.2, macOS 11.1, tvOS 14.3, watchOS 7.2
      Xcode: 12.4/12D4e - /usr/bin/xcodebuild
      expo: ^38.0.0 => 38.0.11 
      react: 16.11.0 => 16.11.0 
      react-dom: 16.11.0 => 16.11.0 
      react-native: https://github.com/expo/react-native/archive/sdk-38.0.2.tar.gz => 0.62.2 
      react-native-web: ~0.11.7 => 0.11.7 
      expo-cli: 4.2.1
    Expo Workflow: managed

(also FYI I tried both on my main project and on a newly created expo init project, and it did nothing in both. I hadn’t initially committed before running and saw a warning so committed and it made no difference)

hey owen! i tried this right now - i initialized a new project and ran expo customize:web - picking index.html - this was the result:

╰─$ expo init testocm                                                                                                                                                                                                                                     1 ↵
✔ Choose a template: › blank                 a minimal app as clean as an empty canvas
✔ Downloaded and extracted project files.
🧶 Using Yarn to install packages. Pass --npm to use npm instead.
✔ Installed JavaScript dependencies.

✅ Your project is ready!

To run your project, navigate to the directory and run one of the following yarn commands.

- cd testocm
- yarn start # you can open iOS, Android, or web from here, or run them directly with the commands below.
- yarn android
- yarn ios
- yarn web
╰─$ cd testocm
╭─~/code/testocm ‹master›
╰─$ ls
App.js          app.json        assets          babel.config.js node_modules    package.json    yarn.lock
╭─~/code/testocm ‹master›
╰─$ expo customize:web
✔ Which files would you like to generate? › web/index.html
╭─~/code/testocm ‹master›
╰─$ gs
On branch master
Untracked files:
  (use "git add <file>..." to include in what will be committed)

nothing added to commit but untracked files present (use "git add" to track)
╭─~/code/testocm ‹master›
╰─$ cd web
╭─~/code/testocm/web ‹master›
╰─$ ls

also using expo-cli@4.2.1

here’s a video recording: stream.new

my guess is that possibly you’re not using spacebar to select the appropriate file, maybe. this type of prompt can trip people up sometimes.

it is the “press space to select” part that is confusing , pressing enter without space will just exit

1 Like

Hey Brent! :slight_smile: :blush: Thanks for trying this out. @ahna was right that I was hitting enter to make my selection instead of spacebar.

I wonder if it’s worth considering accepting user hitting enter with none selected as a “single selection”, or perhaps showing some helpful warning like “no selection made (use space to pick files to create)” if user returns with no selection.

Either way, thanks for all your epic work :metal:


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.