Expo Client not installing on all IOS simulators

Hello there!

I am having an issue where I am unable to install the expo client across all of my IOS simulators (Iphone 12, Iphone 11, etc.). The only simulator where it is installed is the iphone 8, but I would like it to be installed on all of the simulators. I ran “sudo expo client:install:ios” and it said it successfully installed it but it did nothing. No matter how many times I run that command, nothing happens and the expo client is never installed. Also, I use to have it working correctly on my old macbook but ever since I switched to my new one, it does not work. Please help and thanks so much!

2 Likes

I have same issue.
In my case it was installing on iphone 8 plus. Even though only simulator that was opened was iPad Pro. I even removed the iphone 8 plus simulator but then it started to install expo go on the iphone 8… :disappointed:

Hey all, can you let me know what version of the expo-cli you are using as well as what Xcode version? I just tried installing it on a couple different simulator models without issue (SE, 12, 12 mini)

Cheers,
Adam

1 Like

I am running expo-cli version 4.0.16 and Xcode version 12.4.

Expo CLI 4.1.6 environment info:
System:
OS: macOS 11.1
Shell: 3.2.57 - /bin/sh
Binaries:
Node: 14.15.4 - /usr/local/bin/node
Yarn: 1.22.10 - /usr/local/bin/yarn
npm: 7.5.3 - /usr/local/bin/npm
SDKs:
iOS SDK:
Platforms: iOS 14.4, DriverKit 20.2, macOS 11.1, tvOS 14.3, watchOS 7.2
IDEs:
Xcode: 12.4/12D4e - /usr/bin/xcodebuild
npmPackages:
expo: ~40.0.0 => 40.0.1
react: 16.13.1 => 16.13.1
react-dom: 16.13.1 => 16.13.1
react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2
react-native-web: ~0.13.12 => 0.13.18
npmGlobalPackages:
expo-cli: 4.1.6
Expo Workflow: managed

If it helps anyone else, the fix of opening the Simulator first was not working for me at first because I did not have command line tools installed. You can open xCode, go to preferences > locations > command line tools and if that is empty you’ll need to install them. Once they are installed, expo start will give the same error as OP, but you can then use the open -a Simulator && expo start suggestion.

Liteblue