Expo client consistenly "crashing" to a white screen (Untitled experience) without any logs or alerts (iOS only)

Since the last update of the Expo Go app in my iPhone X (Client Version, I’m consistently getting a “crash” when I click a button in my app.

I’m putting “crash” between quotes because what actually happens is that the Expo Go client simply “disconnects” from the experience it was running and changes immediately to this screen:

In the expo CLI there are no logs whatsoever, which makes debugging this very hard.

We tried checking out commits more than 6 months ago, where there’s no possibility of that bug being in our App, and the bug still happens, so we can only nail it down to the Expo Go client update.

Also, I noticed that when I’m on that blank screen, if I shake the device, I get a card stating that I’m on an “untitled experience” and, more importantly, it states a different IP address than I was running (for instance, my experience is listed as on Expo’s “Recently opened” and “Recently in development” list, but when the “white crash” happens, it lists


It’s also not my device’s IP address, which at the moment is

This does not happen in Android.

In iPhone, it’s reproducible 100% of the times I click the “send” button in a specific screen.

Now for the kicker: when I click that button on the iOS simulator running on my Mac, not only it works fine on the simulator, but it has the “power” to “crash to the white screen” the Expo Go client running on the iPhone X immediately.

For future googlers, after 5+ hours of very frustrating debugging, reinstalling the Expo Go app on my iPhone is what solved it.

1 Like

Thanks for sharing the solution with the community, @dev_temporadalivre. The more we can help others avoid those nasty, bang-the-head-against-the-wall debugging sessions, the better!


1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.