Expo Client Bug?

In the Expo Client app there is a “Recently in Development” section in the projects tab. Right now it is showing a grey circle and it says “No projects are currently open”.

I have a project open on my PC and the tunnel is up and running. I am signed in on both. But it is not showing on both Android and iOS Expo Client.

Any idea why it’s not showing?


I am having the same issue, both on real devices and iOS simulators. Signing out/in both in expo-cli and expo client does not help. Starting an app in the simulator by pressing “i” in the console will list the project in the “recently opened” section, but it will still not show in the “recently in development” section.

The only solution to open the projects is to manually add a project (Plus button at the top-right corner) and type the exp://… link (or QR code scan for real devices).

Same here, worked few days ago but not anymore…
The only way is to scan the QR code so doesn’t work in emulator…
Don’t know if this is a iOS feature, but there’s no Plus button on Android.


I had to take a pic of the QR code with my phone, then show it to my laptop camera to open the project in emulator :face_with_raised_eyebrow:

You can copy the exp://… url, and paste it in Chrome. The exp:// protocol will be intercepted by expo, and you’ll be able to open it.
Sorry, cancel that, seems not to work in the emulator… However, if you type the url in the emulator somewhere, then copy the url text, open the expo client, it should say at the top “Open from Clipboard”.

Same issue. There is no any project displays in 'Recenetly in DEvelopment" section.

Also, if you’re suddenly getting this (as I was), and you’re on iOS 14, it could be because the Expo Client app needs access to your local network and unless it requests it, it just sits there and shows nothing is currently running (at least it seemed to for me, in this case). On iOS 14, if something needs local network access you need to grant it. I just set up a new test device on iOS 14 and came across this, despite being logged in to my Expo account on it. What I ended up doing was copying the exp://… URL from the Expo Developer Tools browser tab, pasting in Safari on iOS, allowing it to switch to the Expo Client, and then – and only then, in this case – it asked for access to the local network. As soon as I granted that, I could see the running app and access it from there.

1 Like

Hey everyone, I’m seeing the same behavior on my (iOS 13) phone, will update here once I know more

thanks for reporting!

1 Like

While we investigate, you can workaround this by opening projects:

  • on your device by scanning the QR code with the iOS camera app
  • on your simulator by pressing i after running expo start (or running expo start -i)

Hi, we believe this issue was due to a change in our CORS policy that has now been fixed & deployed.

1 Like

Great! It works now. Thank you :slightly_smiling_face:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.