expo-cli upgrade bug?

Hi there.

I tried upgrading all pacakges related to expo by expo upgrade.
But I could not upgrade almost all of them, which means their versions are same to ones before expo upgrade.

And I got an error in eas build as below.

[!] Unable to find a specification for UMFileSystemInterface depended upon by EXImageManipulator

I think this is caused by versioning difference, then I must have found the way to upgrade the packages.

I tried expo upgrade many times, not work.
It is not smart to try expo install for all packages…

FInally, I found the solution.
I just try expo update, then could solve all problems.

But what is the difference between update and upgrade?
Docs don’t mention about update.
I am afraid of using it anytime because I don’t know how it works exactly.

they are the same command. one is an alias for another.

I know it.
The doc mention update as alias of upgrade.

I don’t have any problem after expo update.
So I will try comparing upgrade and update next time to confirm whether I had mistaken something.