Expo Cli Error, RNOneSignal native module. How I connect Native Modules in Expo Cli

I use expo cli and connect push notification through oneSignal. I am facing this bug ‘‘Could not load RNOneSignal native module. Make sure native dependencies are properly linked’’. I haven’t find solution on internet anywhere. Kindly help and guide me.

It’s not possible to include third-party native code in classic builds or in Expo Go

With eas you can do this, onesignal already provides config plugin so you can use it in managed project GitHub - OneSignal/onesignal-expo-plugin: The OneSignal Expo plugin allows you to use OneSignal without leaving the managed workflow. Developed in collaboration with SweetGreen. and build custom dev client (instead of Expo Go)