Expo cli doesn't respond while opening the project on an android emulator

This is the screenshot of the error

This is my expo diagnostics.

Expo CLI 4.0.17 environment info:
      OS: Windows 10 10.0.18363
      Node: 12.18.3 - C:\Program Files\nodejs\node.EXE
      Yarn: 1.22.5 - C:\Program Files (x86)\Yarn\bin\yarn.CMD
      npm: 6.14.9 - C:\Program Files\nodejs\npm.CMD
      Android Studio: Version AI-201.8743.12.41.6953283
      expo: ^40.0.0 => 40.0.0
      react: 16.13.1 => 16.13.1
      react-dom: 16.13.1 => 16.13.1
      react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2
      react-native-web: ~0.13.12 => 0.13.18
      react-navigation: ^3.11.1 => 3.13.0
    Expo Workflow: managed

go over to expo-cli and try pressing the “a” key when the server is ready - this will attempt to launch the emulator in the same way. what do you see? what if you press “shift+a”?

I tried to press the ‘a’ key but it still isn’t responding. While pressing shift+a in the terminal the
this happens (in the screenshot attached)

Try open android studio and be sure if sdk platform installed and the emulator worked fine in android 10 by clicking on AVD then start the emulator and when boot up try to click on run emulator button in expo localhost: 190003 if its the first time. :grinning:

Sdk is platform tools are installed and updated. The cli is still giving an error

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.