expo-cli 2.20.10 publish error

Receiving the following error when trying to publish after updating to expo-cli@2.20.10:

The same error occur when trying to build ios & android.

Building sourcemaps
Finished building JavaScript bundle in 1970ms.
Finished building JavaScript bundle in 391ms.
Uploading JavaScript bundles
buildPhaseLogger.info is not a function
TypeError: buildPhaseLogger.info is not a function
at Object.getManifestAsync (/@expo/xdl@55.0.10/src/detach/ExponentTools.ts:91:20)
at process._tickCallback (internal/process/next_tick.js:68:7)

Thank you.


I am receiving the same error. I even rolled back to the version I was using earlier today (npm install -g expo-cli@2.20.7) and I still get the error.

This worked for me:

sudo npm install -g expo-cli@2.14.0 --unsafe-perm

I rolled back to exp-cli@2.19.4 and that worked as well.

None of the expo-cli@2.20.xx worked for me, even though like you they had worked earlier.


strange, I guess we should post about it on github and reference this post. There was an expo-cli update about 4 hours ago.

I agree. It seems to have been introduced in a recent @expo/xdl update.

Hey everyone,

Is this happening to you with fresh expo init projects? I just tried myself and wasn’t able to replicate the error :confused:

No. It is an old project. The project that I’ve been trying has existed since Expo SDK 23.

Same issue, with a project that started with SDK 30 (current on 33). I’m also unable to reproduce the issue on a fresh project, so if I’ve got time I may try to isolate a specific dependency or setup difference that triggers it.

Here’s my current package.json that experiences the error:

  "main": "node_modules/expo/AppEntry.js",
  "private": true,
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "eject": "expo eject"
  "dependencies": {
    "@expo/vector-icons": "^10.0.2",
    "expo": "^33.0.0",
    "expo-analytics-amplitude": "^5.0.1",
    "expo-barcode-scanner": "^5.0.1",
    "expo-blur": "^5.0.1",
    "expo-camera": "^5.0.1",
    "expo-constants": "^5.0.1",
    "expo-localization": "^5.0.1",
    "expo-permissions": "^5.0.1",
    "expo-web-browser": "^5.0.3",
    "i18n-js": "^3.3.0",
    "native-base": "^2.12.1",
    "react": "16.8.3",
    "react-native": "https://github.com/expo/react-native/archive/sdk-33.0.0.tar.gz",
    "react-native-render-html": "^4.1.2",
    "react-navigation": "^3.11.0",
    "sentry-expo": "~1.13.0"
  "devDependencies": {
    "babel-preset-expo": "^5.1.0",
    "expo-cli": "^2.20.10"

We got it to work with expo-cli@2.6.14 on iOS for a large production group.

I posted an issue here.

@charliecruzan here are the steps that reproduce it for me. All I did was eject a blank template to ExpoKit. Hope this helps.

i have same problem.

Also having the same issue with a slight different stack trace:

TypeError: buildPhaseLogger.info is not a function
    at Object.configureAsync (/@expo/xdl@55.0.10/src/detach/IosNSBundle.js:459:22)
    at detachIOSAsync (/@expo/xdl@55.0.10/src/detach/Detach.js:296:3)
    at _detachAsync (/@expo/xdl@55.0.10/src/detach/Detach.js:203:5)
    at Object.detachAsync (/@expo/xdl@55.0.10/src/detach/Detach.js:63:12)
buildPhaseLogger.info is not a function

i rolled back to 2.19.4


Version 2.20.11 should fix this issue

1 Like

I just tried using 2.20.11 and encounter the error message “buildPhaseLogger.info is not a function”

I can confirm 2.20.11 fixes the issue for my projects. I updated both globally and in my devDependencies.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.