Expo build with `expo build:ios --config xxxx`

I tried the same expo build:ios without the --config command and it does run. So it seems to be an issue with the build system - the app.json files are identical except for slugs and package’s.

It’s a silent failure all I get is:

“No logs exist” and when I click them I get this:

Your build is errored.
No logs exist for this build yet. Once a build has logs they will appear here.

the link is Log In — Expo for the expo team

hello! can you share the result from expo diagnostics in your project?

to see if i understand correctly: if you run the build with your config in app.json then you don’t encounter any problems, but if you the config to something like app.dev.json and then run expo build:ios --config app.dev.json then your build errors as described above. is this correct?

if this is true, it would very much surprise me. i tried doing this locally just now and it works as expected. the build service actually does not even know what app.json you pointed to, we read it on your machine when we “publish” in order to generate a manifest, and then the build service just reads from that manifest. i just tried this on my machine and it works as expected.

cc @wkozyra - can you see if we have any more context on why https://expo.io/accounts/philia/builds/ae6744aa-88a2-4211-852a-7e62bd52b5fc errored?

I don’t see anything in logs referring to those builds, but if the only difference is the slug and bundle identifier then the most likely issue is with credentials.

  • are you using --skip-credentials-check when building?
  • you could try recreating credentials for this combination of slug and bundle identifier
1 Like

i don’t think expo-cli is respecting the custom --config anymore. It just keeps using the default app.json in the root folder of the project. This is a fairly big issue!

and what expo-cli version are you using where you are experiencing this behavior?


i was using 4.1.4 before and it exhibited the same behaviour

working fine on my machine. will need you to provide some steps to reproduce. if you think this is a bug that you have encountered and not an issue on your end, go to Issues · expo/expo · GitHub and create a new issue and please fill out the issue template

are you doing expo build:web --config app.mycustomfile.json?

note WEB

that also works as expected for me

I found the issue. I ran expo customize:web and extracted just the webpack.config.js. I hadn’t actually made any customizations to it at all even but having a custom webpack config seems to make expo cli skip the --config option. Sounds like a bug to me because there is nowhere in the webpack you can specify a custom app.json config.

if you think you have found a bug then please file an issue on Issues · expo/expo · GitHub

i don’t think that what you are describing is a bug, but i’m open to being convinced in an issue. you may have to use another approach to handle switching configs if you eject webpack config. eg: you could use an env var EXPO_ENV=lanman2000 expo build:web and then in your webpack config handle that accordingly

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.