expo build:ios hangs on Trying to authenticate with Apple Developer Portal...

expo --version: 2:11:8

After entering credentials it never asks for the 6 digit code.

After ctrl-C is shows the following:

"Available session is not valid any more. Continuing with normal login.
Two-factor Authentication (6 digits code) is enabled for account ‘xxx’
More information about Two-factor Authentication: Two-factor authentication for Apple ID - Apple Support

If you’re running this in a non-interactive session (e.g. server or CI) check out fastlane/spaceship at master · fastlane/fastlane · GitHub

(Input sms to escape this prompt and select a trusted phone number to send the code as a text message)

Please enter the 6 digit code:

× Authentication with Apple Developer Portal failed!"

Any idea?

I’m having the same issue, it just seems to hang on “Trying to authenticate with Apple Developer Portal”

Any ideas guys?

Just tested it from my home computer (also Windows 10). From home it works.

Not sure about the differences between office and home. Both networks are ‘private’.

(I recently found out that the expo ‘LAN’ connection doesn’t work when the network is set to ‘public’. At least in my case.)

Still no success in the office. I disabled the Windows firewall, but no luck.

It reaches Apple successfully. I get the verification code on my phone. So, that part works. expo-cli only never prompts me for the code.

Hey @mondunet,

Just for clarification, the entire process worked from your home network?


Correct, the entire process works from home network.


The same here. I just cannot receive any authentication code when using expo-cli. I can access apple account using my notebook and get the 6 digit code on my phone.

On time I have just updated expo version to v 2.11.9 and the sms was prompt!

I updated the CLI to 2.13.0 and building ios is just hanging on “Trying to authenticate…”. I never receive the code on my device. I was receiving it before I upgrade the CLI (not sure which version that was).

Any ideas?

The problem is back! I have updated another machine to cli 2.13.0 and no sms code is sent. The problem was fixed when I upgrade to 2.11.9 some days ago

I reverted to 2.11.9 and that didn’t work for me either. Strange.

I should mention that putting in the wrong credentials still makes it hang which tells me its not related to receiving the code. This isn’t related to not having a port open is it? When I log in to apple on browser I do get verification code.

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.