expo build:ios failed with no logs - no messages - no explanations

Until yesterday, everything was running fine and i was able to build standalone ios package (with adhoc provisioning).

Since this afternoon, when running a build on IOS, i have a build failure with no logs and no messages. (Build for android is still working )

Command line i am using is :
expo build:ios --provisioning-profile-path .\xxxxx.mobileprovision --team-id B-Q

Everything seems to run fine coming to “Build queued” then it fails with no errors

On Expo Build page status (for example 9a963aa0-8ce5-4f80-a835-811a07e3f54f) : I have an errored build status and a no logs exist (not very useful to figure out what’s happen)

From web reading, i tried to reinstal expo-cli with no success

Any Suggestions what i can try to solve this problem ?


Expo diagnostics
Expo CLI 3.27.10 environment info:
OS: Windows 10 10.0.19042
Node: 12.18.3 - C:\Program Files\nodejs\node.EXE
Yarn: 1.22.4 - C:\Program Files (x86)\Yarn\bin\yarn.CMD
npm: 6.14.6 - C:\Program Files\nodejs\npm.CMD
Android Studio: Version AI-193.6911.18.40.6514223
expo: ~36.0.0 => 36.0.2
react: ~16.9.0 => 16.9.0
react-dom: ~16.9.0 => 16.9.0
react-native: https://github.com/expo/react-native/archive/sdk-36.0.0.tar.gz => 0.61.4
react-native-web: ~0.11.7 => 0.11.7
Expo Workflow: managed

Hello again,

I have tried several build with or without adhoc provision file, after deleting my all projects and expo building (etc. etc.) . No success

All was working fine until friday 25 september

Build for Android It works

Build for IOS Failed every time (but until thursday all was working fine)
Last build in error status
05a7e1b6-9c9c-4975-b451-43175420687b (always with no logs or message :
× Build failed.
Standalone build failed!)

Have you a way to give me some informations that can explain my problem ? Any suggestions would be appreciate


Hello again again,

trying a new build after updating to sdk 37

IOS build failed with no errors / log message as usual (EXPO_DEBUG set to true)
× Build failed.
Standalone build failed!

(Android All is ok as usual)

BUILD : d3496bb6-720f-4c49-bb33-5bc239299afd

Is there a way to have a reason why i get this Build failed message ?


Hi again

I still search for a solution…

I have noticed something strange.
When setting an incorrect password (with env var EXPO_NO_KEYCHAIN=1), Process still connecting successfully to Apple Portail !! How is it possible ?!?

Accessing credentials for pjalbert in project ApisArtisRe7
√ Do you have access to the Apple account that will be used for submitting this app to the App Store? … yes
Please enter your Apple Developer Program account credentials. These credentials are needed to manage certificates,
keys and provisioning profiles in your Apple Developer account.
The password is only used to authenticate with Apple and never stored on Expo servers
Learn more here (​https://bit.ly/2VtGWhU​)
? Apple ID: pja@dixtal.fr
? Password (for pja@dixtal.fr): [hidden] (setting an incorrect password)
Skip storing Apple ID password in the local Keychain.
Authenticating to Apple Developer Portal…
Authenticated with Apple Developer Portal successfully! (Wow !)
Using Apple Team with ID: B3Z2653V8Q


In final cause, i created another EXPO account and it works (same code, same build command)

Not a very smart solution !! Must be a cache somewhere on expo server ?


hi all, really sorry the inconvenience. This was caused by a server feature we rolled out to 5% of everyone in production. We’ll be rolling out a fix soon to unblock everyone affected by this, will keep you updated.


Thanks for your feedback

Is there some kind of status page (not turtle build) that could let us know that there are issues going on.

It would have saved me from spending 3 days going crazy and trying to figure out what was wrong and then reinstalling all my project and expo-cli for in desperation delete my expo account for another

The main point is that everything is working fine and you have an explanation for this failure

Thanks for your great work


@pjalbert27 https://status.expo.io/ is the place we use to broadcast issues with our services

we’ve since deployed a fix, builds should be working again on your original account

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.