Expo build IOS Failed to prepare all credentials

Expo diagnostics:

  Expo CLI 4.1.3 environment info:
      OS: macOS 10.15.3
      Shell: 5.7.1 - /bin/zsh
      Node: 12.18.1 - ~/.nvm/versions/node/v12.18.1/bin/node
      Yarn: 1.22.10 - /usr/local/bin/yarn
      npm: 6.14.5 - ~/.nvm/versions/node/v12.18.1/bin/npm
      CocoaPods: 1.10.0 - /usr/local/bin/pod
      iOS SDK:
        Platforms: iOS 13.6, DriverKit 19.0, macOS 10.15, tvOS 13.4, watchOS 6.2
      Xcode: 11.6/11E708 - /usr/bin/xcodebuild
      expo: ~40.0.0 => 40.0.0
      react: 16.13.1 => 16.13.1
      react-dom: 16.13.1 => 16.13.1
      react-native: https://github.com/expo/react-native/archive/sdk-40.0.1.tar.gz => 0.63.2
      react-native-web: ~0.13.12 => 0.13.18
      expo-cli: 4.1.3
    Expo Workflow: managed

Hello !
During the build of my expo app for the ios platform (archive), I got an error concerning the distribution certificate / credentials ?

✔ Select an iOS distribution certificate to use for code signing: › [Add a new certificate]
✔ Will you provide your own Apple Distribution Certificate? › Let Expo handle the process
✔ Created Apple distribution certificate
Failed to set up Distribution Certificate
Failed to prepare all credentials.
The next time you build, we will automatically use the following configuration:
No credentials configured for app @nextriesh/isneaks-app with bundle identifier com.isneaks.app

insert into "credentials_apple_app_identifier" ("account_id", "apple_team_id", "explicit_bundle_identifier", "parent_apple_app_id") values ($1, $2, $3, $4) returning * - column "parent_apple_app_id" of relation "credentials_apple_app_identifier" does not exist.

I could not find any solution / topic about this particular error, I already tried to remove all certificates and generate new ones without success.

Thank you for your help and have a nice day !

facing same issue, I digged around a bit looks like one of their api’s is throwing an error. I suspect this to be an issue with the expo backend.

if you downgrade to expo-cli@4.0.18 do you still have this issue? we’ll look into it, but this will be helpful to know

not sure about 4.0.18 but I downgraded to 4.0.17 and still the same issue, I believe the issue is on the backend and not the cli.

i agree this is likely the case, i just wanted to rule that out. coordinating with the infra team now to get to the bottom of this

tried with 4.0.17 same issue.

Thank you for your answers, I will try it back tomorrow !

We just pushed a fix for this. Hopefully this solves the isse!

1 Like

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.