Expo Build Android Permissions Denied (SOLVED)

exp build:android does not prompt for camera/camera_roll permissions. The process works 100% in the Expo app for android, however the permissions do not prompt for user approval on android using exp build:android.

Is there a solution to this?

exp -V: 56.0.0

This is a major issue when deploying to the Google play store, if the app doesn’t actually have full functionality.

Any help with this is appreciated!

@thisistmp can you post your app.json for us have more info?

Is it the same Error on SDK 29?

  "expo": {
    "name": "appName",
    "icon": "./src/img/icon.png",
    "version": "#.#.#",
    "slug": "app-name",
    "sdkVersion": "27.0.0",
    "description": "more on app.",
    "privacy": "unlisted",
    "orientation": "portrait",
    "primaryColor": "#607D8B",
    "androidStatusBar": {
      "barStyle": "light-content",
      "backgroundColor": "#607D8B",
    "ios": {
      "bundleIdentifier": "com.app.name",
      "icon": "./src/icon/ios/icon.png",
      "supportsTablet": false,
      "infoPlist": {
        "NSCameraUsageDescription": "do go on.",
        "NSPhotoLibraryUsageDescription": "please.",
      "splash": {
        "backgroundColor": "#ffffff",
        "resizeMode": "contain",
        "image": "./src/img/icon.png",
    "android": {
      "package": "com.app.name",
      "versionCode": 7,
      "icon": "./src/img/icon.png",
      "permissions": [
      "splash": {
        "backgroundColor": "#ffffff",
        "resizeMode": "contain",
        "ldpi": "./src/img/icon.png",
        "mdpi": "./src/img/icon.png",
        "hdpi": "./src/img/icon.png",
        "xhdpi": "./src/img/icon.png",
        "xxhdpi": "./src/img/icon.png",
        "xxxhdpi": "./src/img/icon.png",

ran on SDK 27.0.0

also updated to SDK 29.0.0 still no success

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.