Expo Bare vector icons not showing after build:ios (SDK 37)


I’ve been struggling with this for more than a week now, I started my project in the managed workflow, but had to eject to the bare workflow to install some libraries, now for some reason when using any of the @expo/vectore-icons a “missing” icon is displayed (a square with a question mark in it).
They are visible when testing in local but after building with: expo build:ios --no-wait --release-channel prodchannel and uploading to test flight, the icons are gone.
I’m even loading them on app start using: Font.loadAsync(FontAwesome.font) but still no luck.
At this point i’m desperate for a solution so i’m considering to use images to replace all icons…

Please help!


Ok, after having a closer look at the “Bare Workflow Walkthrough” article in the docs i found that releasing to app store is at your discretion and it is not supposed to work with expo build cli tool. This is the only mention i found about this in the docs.
Anyway, seems that to create builds for iOS you still need to do this through xcode. Did that exactly as how i was used to do this when i was working on another project that used ExpoKit and SDK 34, and worked.
Now, my problem is now with Android. I can’t get an apk that works nor an android app bundle (aab) using android studio. The builds get generated and signed but they just don’t work.
Seems that in this case i DO need to create a build using expo build:android??? That’s the only way i got them to work.
Please, is there some one at @expo team looking at this forum that can clarify this for me?


in bare workflow you need to use android studio and xcode to do the builds for you, that is correct

1 Like

I’m running into the same problem in the managed workflow in SDK 37. I’m trying to rebuild after updating @expo/vectore-icons and preloading the fonts. Apple and Expo aren’t working together today with expo cli to rebuild. When I do expo publish the problem persists.

do you have an ios or android directory in your project? do you have react-native-unimodules installed?

I have the ios and android directories. I also recently did the updated asset bundles as part of the SDK 37 upgrade in the managed workflow. I do not have react-native-unimodules installed.

I was hoping that once I can build the Apple version, this issue might go away – working on that but having trouble the apple distribution certificates (Apple credentials are unavailable - #16 by kickinespresso)

if you have ios and android directories it means it’s a bare project. you should delete those if you’re not using them. otherwise you need to use those to produce your builds

Is there an easy way to switch back to the managed workflow? I never wanted the bare workflow.

delete the ios and android directories, remove react-native-unimodules from package.json if you have it there, and you’re done!

1 Like

Thanks. Let me give that a shot.

@notbrent suggestion of deleting the ios and android directories worked for me. SDK 39.0.3