Expo application run fine locally and its Apk built successfully too. But apk file doesnt work on any device and keep closing.

In your post, please share:

  • our eas-cli version - 3.2.1
  • We have tried apk in all different devices and in android studio too to check compatibility. But still its not working and closing automatically.
    To build apk, we use eas build -p android --profile preview
    We checked using expo start -c to run locally and no error found.

Any help or suggestion would be appreciated.

Thank you

If it works in Expo Go, then first check that you do not have ios and android directories in your app.

If you did have those and you deleted them, then try building again to see if that fixes it.

If there’s still a problem, try running expo start --no-dev --minify and see if it crashes in Expo Go. If so, you can more easily see what is going wrong and fix it.

Otherwise, see the Debugging guide

See also: Troubleshooting build errors and crashes - Expo Documentation


Thanks for your guidance. It does help us to understand in more details. Though , we managed to sort out using android studio’s log file.

Found out four below packages which were causing to run on android studio as well as our devices. -

  1. react-native-autoheight-webview
  2. expo-file-system
  3. expo-permissions
  4. expo-media-library packages

After removal of all packages and related code, it worked in every device.

So I would suggest to all developers to check compatibility after adding new packages as Expo and eas-cli behave slightly different to have your successful apk file.


This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.