Expo App showing white screen in test flight

Please provide the following:

  1. SDK Version: sdk-42.0.0
  2. Platforms(Android/iOS/web/all): IOS
  3. Production build

I recently deployed my expo app to playstore and app store. It works fine in play store but in IOS it shows the splash screen briefly and then a white blank screen and stays like that forever. It is not crashing , so no crash report. It is very difficult for me to understand why this is happening. I ran the same build locally in prod mode using “expo start --no-dev --minify” and it works fine both on IOS simulator and on the IOS device. So I suppect may be the process of build the app and uploading via EAS might be the issue?

Hmm I had the same issue when upgrading to SDK 40. Only thing I did was reinstalling expo-cli and it worked.

Don’t know if that could be the case for you as well - would be quite strange.
Which crash reporter are you using?

1 Like

I tried to use sentry, followed the documentation in the expo but could not get it to work. It given “Invalid DNS” number error but the DNS number is correct because I copied it from my sentry account. So maybe their documentation is not up to date.

1 Like

Hmm, have you tried to connect to your device and inspect the error logs while running the AppStore Built version?

how do I do this? I ran the production build using “expo start --no-dev --minify” and it works fine on device no issue.

Connect your iOS device to your Mac and follow these instructions:

1 Like

Please see

See screenshot, I could not use this as well. I hope I can get this resolved as soon as possible.

Finally, issue is resolved for me. I have to use “expo build:ios” and upload the archive file through the transporter to app store. So I guess there is an issue using eas to build and submit.

1 Like

Interesting … And very strange.
I switched to eas yesterday and im using just the build and submit it via transporter and everything works fine