Expo app crashing in production: @react-native-community/netinfo

Please provide the following:

  1. SDK Version: 44
  2. Platforms(Android/iOS/web/all): Android

My managed app has been working fine in production so far (Google Play). Recently I published a new updates with simple bug fixes (a couple of lines of code). I have not installed a new npm library nor made some configuration change. After that, now app is crashing in production, at start with fatal error:

com.facebook.react.common.JavascriptException: Error: @react-native-community/netinfo: NativeModule.RNCNetInfo is null. To fix this issue try these steps:
• Run react-native link @react-native-community/netinfo in the project root.

I’m not even using @react-native-community/netinfo in my application.
App is running fine locally (Expo Go) in debug or production mode.

How can I debug this issue and understand why @react-native-community/netinfo is suddenly failing my build?

Thank you for your assistance.

Hey @seyaobey, can you share your package.json? Also, did you build your project with eas build or expo build?

Thank you for the prompt answer. I was able to find a solution by following these links

I have been using bugsnag in my app. Not sure why it worked for few days (I installed bugsnag then I ran eas buid and created a new production release. That release has worked a few days, not sure how…). And then it started breaking after the last eas publish (with simple lines changes).

Anyway after I ran expo install @react-native-community/netinfo and then eas build, now my app in production is working.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.