Expo app crashes on start in Testflight but runs fine in production mode “expo start –no-dev –minify”

Hello Expo support team,

I am experiencing an issue with my Expo app where it is crashing on start when installed through TestFlight, but runs fine with production mode “expo start --no-dev --minify”. I’ve tried a few things to resolve the issue, but so far nothing has worked.

Here are some details about my app and environment:
expo 47
Steps to reproduce the issue:

  1. Install the app through TestFlight
  2. Launch the app
  3. App crashes on start

Here are some things I’ve tried to resolve the issue:

  • Checked the error logs in TestFlight, but didn’t find any useful information
  • Built the app with production settings using “expo build:ios -t simulator --no-dev --minify”
  • Checked for differences in dependencies and configuration settings between development and production

None of these steps have resolved the issue. I’m not sure what else to try at this point. Could you please provide any suggestions or assistance you can offer to help me resolve this issue?

Thank you for your time and help.