Expo App crashes in Android Phone or Emulator (BlueStack ,LDPlayer4)

As i have tried reinstall the Expo in the all platforms such as Android Phone and Emulator (BlueStack4 ,LDPlayer4) but none of that worked i gues there is fault with the App as it was
working fine at the beginning but some timed it crashed .
package.json is :

  "main": "node_modules/expo/AppEntry.js",
  "scripts": {
    "start": "expo start",
    "android": "expo start --android",
    "ios": "expo start --ios",
    "web": "expo start --web",
    "eject": "expo eject"
  "dependencies": {
    "expo": "~41.0.1",
    "expo-status-bar": "~1.0.4",
    "react": "16.13.1",
    "react-dom": "16.13.1",
    "react-native": "https://github.com/expo/react-native/archive/sdk-41.0.0.tar.gz",
    "react-native-web": "~0.13.12",
    "expo-permissions": "~12.0.1"
  "devDependencies": {
    "@babel/core": "^7.9.0"
  "private": true

App.json is :

  "expo": {
    "name": "myproject",
    "slug": "myproject",
    "version": "1.0.0",
    "orientation": "portrait",
    "icon": "./assets/icon.png",
    "splash": {
      "image": "./assets/splash.png",
      "resizeMode": "contain",
      "backgroundColor": "#ffffff"
    "updates": {
      "fallbackToCacheTimeout": 0
    "assetBundlePatterns": [
    "ios": {
      "supportsTablet": true
    "android": {
      "adaptiveIcon": {
        "foregroundImage": "./assets/adaptive-icon.png",
        "backgroundColor": "#FFFFFF"
    "web": {
      "favicon": "./assets/favicon.png"

Hey @m2c, for clarification, are you saying the crash occurs when testing on a physical android device as well? If so, can you let me know what the device model/OS version is? Also, can you see if a freshly made, new expo project will crash as well? I’m not too familiar with Bluestack or LDP but have you tried the emulators provided by Android Studio?


1 Like

As first it working fine in BlueStack !. The Physical device is Oppo which updated . and the Expo app is also updated .

I tried the newly created Expo app but first it worked fine and now it’s crashing again.

I tried on latest device possible but still crashes

This post was flagged by the community and is temporarily hidden.