Expo Andriod deployment issue

$ expo diagnostics

Expo CLI 4.0.13 environment info:
OS: Windows 10 10.0.18363
Node: 12.18.3 - C:\Program Files\nodejs\node.EXE
npm: 6.14.6 - C:\Program Files\nodejs\npm.CMD
Android Studio: Version AI-193.6911.18.40.6626763
expo: ^38.0.0 => 38.0.10
react: 16.11.0 => 16.11.0
react-dom: 16.11.0 => 16.11.0
react-native: https://github.com/expo/react-native/archive/sdk-38.0.2.tar.gz => 0.62.2
react-native-web: ~0.11.7 => 0.11.7
Expo Workflow: managed

When I am running - expo build:android -c
It works well till Key alias
after I provide the value it does not go the next step. It is stuck at
? Key alias » xxxxxxxx

If I click enter again it takes the alias value as null and throws the following error
"keystore.keyAlias" is not allowed to be empty.

I would really appreciate any help, stuck on deployment for the past two days.

Thank you in advance

Hey @vasudhan, are you still getting stuck at this step? If so, could you let me know if this also happens to you when try it with a newly created project?


Thank you for responding. Yes, I am still stuck. Another Person deployed the app to playstore before, so I have to use the same key so following this procedure. But if I use the expo generated key the build works well but I can’t use that for playstore. I have never tried build a new app with custom key

Little more input: when I even try the following command - it is stuck on the same step
expo credentials:manager -p android
I tried to create the credentials using keytool -genkeypair -v -keystore keystore.jks -alias keyalias
and used that .jks file, but it still is stuck on the step
? Key alias » xxxxxxxx

I am facing the same issue. I have entered the alias, when I press enter it goes to new line and is stuck.
Pressing enter again asks for key password, I enter it and press enter and the error is displayed.
“keystore.keyAlias” is not allowed to be empty

Can someone help, been trying to generate an APK but not able to process due to this error.

Sorry that you are running into this issue too, in my case I tried a different windows machine thinking may be it is an issue with my machine or my software. But running into the same issue there too. It is working fine for me when I do the same process on Mac, Which is how I am deploying now. I believe the initial key was generated on mac when another employee did it and may be it is not working with windows, no clue there. I would recommend you try on a Mac or Linux (on both it works for us now).

Sadly, I don’t have a mac. I generated the key on my current system and am using that only.
I generated a key using java keytool, Can you suggest any other way of creating key.

I Used below command

keytool -genkey -v -keystore docque-app-key.keystore -alias docque-app-key -keyalg RSA -keysize 2048 -validity 10000

Sorry, I am new to all this, still in learning stage. I generally use the key that was already generated and given to me. when I tried to create my own key to test this, I used similar command (instead of .keystore, I gave .jks file)

keytool -genkeypair -v -keystore keystore.jks -alias keyalias -keyalg RSA -keysize 2048 -validity 9125

@adamjnav, Hey Adam, can you help with this issue ?

@adamjnav, Hey Adam, can you help with this? I’m having this issue too and can’t build nothing to android.

Hi Omer, you are also trying this on a windows machine ?

Yes I do.

Any luck in building APK ? I am also stuck since a month.

if you believe you have encountered a bug, please post an issue to Issues · expo/expo-cli · GitHub and provide as much information as possible (your operating system, your terminal app, your shell, expo-cli version, etc.).

as a sanity test, i just downloaded a keystore, removed, and re-added and it worked as expected on my macos / iterm 2 / zsh / expo-cli@4.0.17 machine.

also, you can use the web ui instead of expo-cli if you’re having problems in your terminal:

This topic was automatically closed 20 days after the last reply. New replies are no longer allowed.