Expo and picker issues

Please provide the following:

  1. SDK Version: expo": “~46.0.9”
  2. Platforms(Android/iOS/web/all): android & IOS
  3. Add the appropriate “Tag” based on what Expo library you have a question on. Picker

Hi Just trying to implement picker for multiplatform in a very simple App, literally just the picker. But Somehow its not working with SDK 46.0.9 using react-native": "0.69.5 and “@react-native-picker/picker”: “2.4.2”. Does anyone know ho to make it work or if I have to downgrade to sdk 45 and just use react 17?

Hey @jaia, what type of issue are you facing with the picker library?

Recently, there was an issue with installing it, see here: Upgrading from SDK 45 to 46 and react version 18 - #3 by ingegnosi

Is that the issue you are also facing?

Yeah its that smame issue, although i tried both flags and still broke the code.

Did you try npm install @react-native-picker/picker@2.4.4 --legacy-peer-deps?

Can you elaborate more on what broke?

Yeah I tried botn npm install @react-native-picker/picker@2.4.4 --legacy-peer-deps and on a separate occasion i tried npm install @react-native-picker/picker@2.4.4 force. Both failed to install

You can try other workarounds such as using yarn (also mention in an open issue here: Incompatible with react-native@0.69 · Issue #425 · react-native-picker/picker · GitHub) as it doesn’t enforce peer dependencies.

Just tried by creating a project with SDK 46 which comes with React Native version 0.69.x and installing npm install @react-native-picker/picker@2.4.4 --legacy-peer-deps is installing successfully.