Expo and Detox on iOS

Hi everyone,

I’ve tried to follow the instruction at Testing Expo Apps with Detox and react-native-testing-library | by Josh Justice | Exposition but I’m stuck with this error when running detox test command:

detox[47811] INFO: [test.js] configuration="ios.sim" artifactsLocation="artifacts/ios.sim.2020-06-04 12-32-46Z" recordLogs="none" takeScreenshots="manual" recordVideos="none" recordPerformance="none" reportSpecs=true node_modules/.bin/jest --config=e2e/config.json --maxWorkers=1 '--testNamePattern=^((?!:android:).)*$' "e2e" detox[47813] INFO: [DetoxServer.js] server listening on localhost:54418... detox[47813] ERROR: [index.js/DETOX_INIT_ERROR]

Error: field CFBundleIdentifier not found inside Info.plist of app binary at /Users/connido/Desktop/Connido/bluebell-app/packages/intouch/bin/Exponent.app

I’ve searched for a solution but could not found anything of help. I’m using latest versions of Expo and Detox.

Anyone can help?

I havn’t tried detox with expo yet, so this might be a wild shot, but have you set your bundle identifier in you app.json file? E.g.

"expo": {
   "ios" : {
    "bundleIdentifier": "com.write.some.unique.url"

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.