Exp published but not update + need to fetching keystore

Continuing the discussion from Exp publish not updating builds:

Hello there!
I have run exp publish too, then i’ve run exp build:ios and exp build:android
But in stores my apps did not update.
I have some problems with publish, because, this app (and other few) was published into stores not by myself, not from expo company account, but from different account of developers who was fired (in Apple store and Google play)

  1. I have run exp fetch:android:keystore and make my own certificate to ios, and there was ok, i’ve already published new versions before, til this time…something was going wrong, and i do not know why. I didn’t change anything in expo settings.
  2. I have some problems how clear old keystore, and upload my own keystore to successfully publish to android, could you please tell me step by step what must i do.

Oh, and here is my last build:
iOS - https://expo.io/builds/501f7e55-0be8-48da-97cc-cc1e80f9fcf6
Android - https://expo.io/builds/f45e461e-77da-4ffc-a324-86740131141a

Will be really glad for any help!
Thank you! :heart:

What do you mean by “in stores my apps did not update”? You have to download ipa/apk from expo and upload them to Apple App Store and Google Play Store.

Hey! Thanks for your answer…again :sweat_smile:
I mean that in past i just run command exp build:ios and it was okey, untill this time.
“in stores my apps did not update” - i mean that on users phones nothing changes.

So, you wanna tell me, that “in this time” i must download ipa\apk and publish new versions into stores by myself?
But what have been changed?

If you do exp publish and change the SDK version then on user’s phone they won’t get the updatem you will need to upload the newly built the ipa/apk to the store and then users will need to download new build to get the update

I do not :disappointed_relieved:
Nothing has been changed in configs!
Like always i run exp build:ios, and like always i expected that my OTA will works well. And my users get new update. But it wasn’t.

Can the problem hide in package.json? with some dependencies with ^ versions?

And i found something interesting…

this is recent builds for my app…is it normal that i don’t see later builds?

Hello again!
Please, i need your help!:disappointed_relieved:
Have you any idea what’s going wrong?

OK, you probably build your previous versions of app from different Expo account. OTA updates are tied to username, so they’ll not work from different account.

Solution is:

  1. use the same account as before,
  2. upload your new apps to Apple/Google store.

It is really hard problem!
This apps have lot of users, how i will handle this?!

Few weeks ago i published updates from my account on Apple store, and OTA works!
But Google store not.

okay, i understood…so i will build app then download and publish by myself, like you say upper.
But as you can see in Android build logs, i have some troubles with keystore…
I found an answer - install KeyStore Explorer and made new keystore. Is it right?

now i have problems with uploading on Apple Store SHA1 fingerprint is different!

Thanks that you try to help me…
It solved by find i person who published apps at first time and ask him for an account…but it was really hard, becouse this person was fired long time ago.

Could i handle change account email?

Hey @just0110,

You can change the e-mail on the Settings page Log In — Expo



This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.