exp.host out of reach warning

Hi Guys

I’m getting the following warning in my console for the last couple of hours.

Warning: could not reach `exp.host`.

We couldn't reach some of our domains, this might cause issues on our website or services.

Please check your network configuration and try to access these domains in your browser.

Since then my RN app on emulator is throwing a weird error related to the i18n-js expo library:

[Unhandled promise rejection: TypeError: locale.split is not a function. (In ‘locale.split("-")’, ‘locale.split’ is undefined)]

I haven’t touched the code and everything was working fine yesterday.

Is everything ok with expo server? Any idea?

Many Thanks

I am getting this similar error (happy im not the only one)

I see it when running NPM start as an issue in the Metro Bundler
And also when trying to publish any package (one that worked fine last time and a whole new one from just expo init.

The messages i receive are:

Warning: could not reach exp.host.

We couldn’t reach some of our domains, this might cause issues on our website or services.
Please check your network configuration and try to access these domains in your browser.

Starting Metro Bundler.
Building iOS bundle

Hi @maxaquilino and @xuthal,

We recently added a quick network check to see if our services are accessible. Normally, this would only run when running $ expo doctor but I see this is happening for you when starting the packager as well. I’m sorry that happens, and we will patch that asap!

About the warning itself, it’s not necessarily an error. It only means that we can’t connect to exp.host, which is one of our API endpoints. Could you check if either https://exp.host or https://exp.host/@bycedric/BareTest/index.exp?sdkVersion=38.0.0 works for you?

As for you @xuthal, it looks like if you terminate the CLI and remove the .expo folder, it should be fixed.

As for you @maxaquilino, it looks like you have an issue in your code. It tries to split something from a locale method, wrapped inside promises, which is either not set or undefined.

Hope this helps!

Hi @bycedric

Thank you for the quick reply.

I can confirm that I can access https://exp.host/@bycedric/BareTest/index.exp?sdkVersion=38.0.0 however https://exp.host is returning “Not found”


@maxaquilino perfect, yes the root will return with “404 not found”. It’s not an endpoint that’s serving our website, so it might be throwing that. But the message with Warning: could not reach exp.host. is still popping up for you? Could you try 1 more command, if this warning still pops up: ping exp.host?

Again, we will try to push a fix asap.

@bycedric - Looks like its up and running again as I’m getting some response from ping.

Warning message seems to be gone as well. It could be intermittent.

@maxaquilino, awesome thanks for the feedback. I created this pull request, when that’s merged and deployed it should be fixed!

Thanks for the feedback @maxaquilino
Good to know that the warning message is only a visual thing. I am able to connect to both urls with the browser, and Ping works fine as well.

I was thinking that the connect ECONNREFUSED would be connected to the warning, but guess that it is something else.
I did as you suggested, i terminated the CLI with ctrl+c and removed the .expo folder from the project. Tried this with both a new project and an exsisting one. But the error kept happening for both of them.

What I did notice is that if I publish again without terminating the application then it will publish succesfully.
Every first publish of my projects will fail with connect ECONNREFUSED
Each publish after that succeeds.

Perhaps you have another tip on how to solve this, otherwise ill just learn to publish dubble for a while

Kind regards and thanks for support!

Can you guide what the next step is because the error ‘could not reach exp.host’ is still not resolved.

Same here. I tried updating expo, I did a exp ping and it didn’t return any problems. I’m trying to connect with my firebase database but it seems like I have a problem too. Anybody able to help?

I started getting this warning immediately after upgrading to v3.24.1. But everything works as normal.

same, got the error immediately after upgrading to the latest expo version

I’m experiencing same issue.

I am experiencing the same issue…

I’m experiencing this warning after I have installed the latest version of expo-cli. Thanks to @bycedric for the explanation.

I upgraded expo-cli to 3.24.2 and the error is gone.


Me too, since the upgrade the warning has kept away.

Just a side note…
I have strong feeling that that problem was causing side effects to my App in particular to the Expo Localization i18n-js package, throwing strange error messages such us “…object undefined”

I’ve not changed any code and now App is working again without a problem.

this change would be unrelated to any errors you’re seeing from i18n-js. the diff for the change is here: https://github.com/expo/expo-cli/commit/7fcfce04f46c0444446e3636298d76cb1c62abdd - this code would not result in any actual changes in how your app runs.

Hi Xuthal,

I have the same issue as you. After upgrading expo-cli to 3.24.2, the first time I press “Publish”, it will show ECONNREFUSED but the next times it will work without errors.

I think there is a problem with version 3.24.2.

Same for me